Sure you have the Flash plug-in? This program requires javascript enabled and version 8 or higher of the Adobe Flash Player plug-in. For the best user experience turn on your speakers.